Incidencia #168 (closed Defecto: Resuelto)

Abierto hace 7 años

Última modificación 7 años

Error luego de safe-upgrade

Informado por: renyalvarado Propietario: guerrerocarlos
Prioridad: Alta Hito: canaima-popular-3.0~VC3
Componente: Metadistribución Versión: 3.0
Gravedad: Palabras clave:
Cc: Asignar A:

Descripción

Luego de hacer un safe-upgrade al sistema, no se puede instalar ningún otro paquete ya que parece que hay problema con el paquete canaima-plymouth

ralvarado@multivac:~$ sudo aptitude install ruby-full | tee aptitude.log
Leyendo lista de paquetes...
Creando árbol de dependencias...
Leyendo la información de estado...
Leyendo la información de estado extendido...
Inicializando el estado de los paquetes...
Escribiendo información de estado extendido...
Leyendo las descripciones de las tareas...
Se instalarán los siguiente paquetes NUEVOS:

ri{a} ri1.8{a} ruby-full ruby1.8-dev{a}

Se configurarán los siguientes paquetes que están ahora parcialmente instalados:

canaima-acerca canaima-bienvenido canaima-escritorio-gnome
canaima-estilo-visual canaima-notas

0 paquetes actualizados, 4 nuevos instalados, 0 para eliminar y 1 sin actualizar.
Necesito descargar 0 B de ficheros. Después de desempaquetar se usarán 49,5 MB.
¿Quiere continuar? [Y/n/?] Y
E: No se pudo localizar un archivo para el paquete canaima-plymouth. Esto puede significar que necesita arreglar manualmente este paquete.
Escribiendo información de estado extendido...
E: No se pudo localizar un archivo para el paquete canaima-plymouth. Esto puede significar que necesita arreglar manualmente este paquete.
E: Error interno: no se pudo generar la lista de paquetes a descargar

y al intentar reinstalar el paquete tenemos:

ralvarado@multivac:~$ sudo aptitude clean
ralvarado@multivac:~$ sudo aptitude install canaima-plymouth
Se actualizarán los siguientes paquetes:

canaima-plymouth

Se configurarán los siguientes paquetes que están ahora parcialmente instalados:

canaima-acerca canaima-bienvenido canaima-escritorio-gnome canaima-estilo-visual canaima-notas

1 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 3506 kB de ficheros. Después de desempaquetar se usarán 0 B.
¿Quiere continuar? [Y/n/?] Y
Des:1 http://repositorio.canaima.softwarelibre.gob.ve/ roraima/usuarios canaima-plymouth all 1.0+18 [3506 kB]
Descargados 3506 kB en 9seg. (361 kB/s).
(Leyendo la base de datos ... 163113 ficheros o directorios instalados actualmente.)
Preparando para reemplazar canaima-plymouth 1.0+16 (usando .../canaima-plymouth_1.0+18_all.deb) ...
Desempaquetando el reemplazo de canaima-plymouth ...
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
update-initramfs: deferring update (trigger activated)
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: aviso: el subproceso script de `post-removal' antiguo devolvió el código de salida de error 1
dpkg - probando el script del nuevo paquete en su lugar...
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
update-initramfs: deferring update (trigger activated)
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error al procesar /var/cache/apt/archives/canaima-plymouth_1.0+18_all.deb (--unpack):

el subproceso script post-removal nuevo devolvió el código de salida de error 1

configured to not write apport reports

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)

update-initramfs: deferring update (trigger activated)
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error al reorganizar:

el subproceso script post-removal nuevo devolvió el código de salida de error 1

Procesando disparadores para initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-5-686
Se encontraron errores al procesar:

/var/cache/apt/archives/canaima-plymouth_1.0+18_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
dpkg: problemas de dependencias impiden la configuración de canaima-estilo-visual:

canaima-estilo-visual depende de canaima-plymouth; sin embargo:

El paquete `canaima-plymouth' no está instalado.

dpkg: error al procesar canaima-estilo-visual (--configure):

problemas de dependencias - se deja sin configurar

dpkg: problemas de dependencias impiden la configuración de canaima-bienvenido:

canaima-bienvenido depende de canaima-estilo-visual (>= 3.0); sin embargo:
El paquete `canaima-estilo-visual' no está configurado todavía.

dpkg: error al procesar canaima-bienvenido (--configure):

problemas de dependencias - se deja sin configurar

dpkg: problemas de dependencias impiden la configuración de canaima-escritorio-gnome:

canaima-escritorio-gnome depende de canaima-bienvenido (>= 3.0); sin embargo:
El paquete `canaima-bienvenido' no está configurado todavía.
canaima-escritorio-gnome depende de canaima-estilo-visual (>= 3.0); sin embargo:
El paquete `canaima-estilo-visual' no está configurado todavía.

dpkg: error al procesar canaima-escritorio-gnome (--configure):

problemas de dependencias - se deja sin configurar

dpkg: problemas de dependencias impiden la configuración de canaima-notas:

canaima-notas depende de canaima-estilo-visual (>= 3.0); sin embargo:
El paquete `canaima-estilo-visual' no está configurado todavía.

dpkg: error al procesar canaima-notas (--configure):

problemas de dependencias - se deja sin configurar

dpkg: problemas de dependencias impiden la configuración de canaima-acerca:

canaima-acerca depende de canaima-estilo-visual (>= 3.0); sin embargo:
El paquete `canaima-estilo-visual' no está configurado todavía.

dpkg: error al procesar canaima-acerca (--configure):

problemas de dependencias - se deja sin configurar

Se encontraron errores al procesar:

canaima-estilo-visual
canaima-bienvenido
canaima-escritorio-gnome
canaima-notas
canaima-acerca

Historial de cambios

comment:1 Cambiado el 7 años por guerrerocarlos

  • Estado cambiado de new to accepted
  • Propietario cambiado de Canaima a guerrerocarlos

Esto se debe a que en la VC1 y VC2 no se instalaba el burg correctamente, para solucionarlo debe ejecutar:

sudo burg-install "(hd0)"

comment:2 Cambiado el 7 años por guerrerocarlos

  • Estado cambiado de accepted to resolved
  • Resolución establecido a Fijada

Prueba realizada, el comando exacto para corregir el error es:

burg-install --force /dev/sda

siendo "sda" el disco donde se encuentra el arranque, para visualizar los discos se puede utilizar el comando "fdisk -l"

comment:3 Cambiado el 7 años por HuntingBears

  • Estado cambiado de resolved to closed

comment:4 Cambiado el 7 años por HuntingBears

Esto es un error que se origina por la instalación inapropiada del BURG en las Versiones Candidatas 1 y 2, por favor seguir las recomendaciones indicadas en el comentario anterior. El defecto ha sido corregido para las Versiones Candidatas 3 y 4.

Nota: Vea TracTickets para ayuda en el uso de incidencias.