Incidencia #222 (closed Defecto: Resuelto)

Abierto hace 7 años

Última modificación 6 años

No se puede usar EXT4 en el instalador usando Gparted

Informado por: ynneko@… Propietario: HuntingBears
Prioridad: Alta Hito: canaima-popular-3.1~VC2
Componente: Metadistribución Versión: 3.0
Gravedad: Trivial Palabras clave: instalador, ext4
Cc: Asignar A:

Descripción

Probando Canaima GNU/Linux en una MV intenté usar una partición EXT4 para el sistema usando la opción avanzada de Gparted, se crea sin problemas, pero al regresar al instalador sale:
"ERROR: No se han encontrado particiones válidas.
Si quieres instalar Canaima GNU/Linux en tu equipo debes crear una partición de tipo EXT3.

Pulse atrás e inténtelo de nuevo."

1-. Debe permitir extensiones EXT4 (no probé otras)
2-. El texto NO debería decir explícitamente una EXT3, sino cualquier otra, EXT3 podría ser una recomendación, pero parece como mandatorio.
3-. Dice que pulse atrás, pero NO hay un botón atrás.

Historial de cambios

comment:1 Cambiado el 7 años por jesuslara

Hay que tomar en cuenta varias cosas:

  • El soporte a ext4 como módulo del kernel pre-cargado, parece tener problemas "por algún motivo" en Canaima VC4
  • No se puede arrancar un sistema (/boot) desde XFS, JFS u otras, solamente desde EXT*
  • / (root) puede estar en cualquier FS que soporte GRUB2 (y en este caso BURG)

Intensificar las pruebas al respecto ... el soporte desde instalación de EXT4 y BTRFS es crítico para el soporte a servidores de Canaima.

comment:2 Cambiado el 7 años por HuntingBears

  • Propietario cambiado de Canaima a HuntingBears
  • Estado cambiado de new to accepted
  • Hito cambiado de Canaima-3.0~VC4 to Canaima-3.0.1~alpha

Ésta mejora/defecto requiere una reestructuración mayor del paquete canaima-instalador-vivo. Posponiendo a la próxima versión.

comment:3 Cambiado el 7 años por HuntingBears

  • Hito cambiado de Canaima-3.0.1~alpha to Canaima 3.0

Inicio del ciclo de desarrollo para Canaima nombre código "Auyantepui" (3.0.1/3.1). Moviendo todos los tickets activos pertenecientes a la versión 3.0 al Hito "Canaima 3.0".

comment:4 Cambiado el 6 años por ssolano

  • Estado cambiado de accepted to resuelta
  • Resolución establecido a Fijada
  • Gravedad establecido a Trivial

Esta incidencia fue solucionada para la versión 3.1

comment:5 Cambiado el 6 años por ssolano

  • Estado cambiado de resuelta to revision

comment:6 Cambiado el 6 años por HuntingBears

  • Estado cambiado de revision to assigned
  • Resolución Fijada borrados

¿Commit? ¿Paquete? ¿Versión del paquete?

comment:7 Cambiado el 6 años por erickcion

  • Estado cambiado de assigned to resuelta
  • Resolución establecido a Fijada

El paquete canaima-instalador ya soporta particiones ext4, este instalador está presente a partir de Canaima 3.1 VC1 y en su código fuente se detalla los tipos de particiones aceptadas por la función particionar(self, disco, tipo, formato, inicio, fin) ubicada en el archivo src/clases/particiones.py.

https://www.gitorious.org/canaima-gnu-linux/canaima-instalador/blobs/dc904a55904598a8ca29495dba92ab3934e8133a/src/clases/particiones.py#line123

comment:8 Cambiado el 6 años por erickcion

  • Estado cambiado de resuelta to closed
Nota: Vea TracTickets para ayuda en el uso de incidencias.