Incidencia #460 (closed Error: Resuelto)

Abierto hace 6 años

Última modificación 6 años

python-apt no actualiza correctamente

Informado por: HuntingBears Propietario: HuntingBears
Prioridad: Normal Hito: canaima-popular-3.1~VC2
Componente: Canaima Popular Versión: 3.1
Gravedad: Trivial Palabras clave: canaima, error
Cc: Asignar A:

Descripción (modificado por última vez por HuntingBears (diferencia)

Al probar una actualización Canaima Popular 3.0 -> Canaima Popular 3.1, el paquete no se actualiza correctamente.

En 3.0 la versión del paquete es '0.7.100.2+canaima0' y en 3.1 '0.7.100.2-1canaima2'. Al parecer APT no interpreta el guión '-' como versión superior con respecto a '+'.

Historial de cambios

comment:1 Cambiado el 6 años por HuntingBears

  • Estado cambiado de new to accepted
  • Propietario cambiado de Canaima Popular a HuntingBears
  • Descripción modificado (diferencia)

comment:2 Cambiado el 6 años por ssolano

  • Estado cambiado de accepted to resuelta
  • Resolución establecido a Fijada

Esto fue solucionado con una nueva versión del paquete (0.7.100.2-1canaima1) el commit en el siguiente link[1]

[1] https://gitorious.org/canaima-gnu-linux/python-apt/commit/67abe7e2028388a50bec3445d5055abe99dbd90f

comment:3 Cambiado el 6 años por willicab

  • Estado cambiado de resuelta to closed

Se cierra ticket (comment:2)

comment:4 Cambiado el 6 años por HuntingBears

Es python-apt 0.7.100.3-1canaima1, ¿No?

Nota: Vea TracTickets para ayuda en el uso de incidencias.