Incidencia #470 (assigned Error)

Abierto hace 6 años

Última modificación 6 años

Mysql-server (ERROR AL INSTALAR)

Informado por: alqx Propietario:
Prioridad: Alta Hito: Soporte Técnico
Componente: Canaima Popular Versión: 3.1
Gravedad: Importante Palabras clave: canaima, error
Cc: Asignar A:

Descripción

hola muchachos estoy tratando de instalar mysql y me da un error tipo 1, los datos están en los pantallazos.

Adjuntos

Pantallazo-1.png (192.6 KB) - añadido por alqx hace 6 años.
Pantallazo.png (150.6 KB) - añadido por alqx hace 6 años.
mysql-server-install.log (4.6 KB) - añadido por erickcion hace 6 años.
Salida de la Instalación de Mysql Server
screenshot2.png (79.3 KB) - añadido por alqx hace 6 años.

Historial de cambios

Cambiado el 6 años por alqx

Cambiado el 6 años por alqx

comment:1 Cambiado el 6 años por elwuilmer

Intenta instalar las dependencias que te pide si no están instaladas:
mysql-server-5.1
mysql-server

Y luego reconfigura el paquete mysql-server
dpkg-reconfigure mysql-server

Verifica en synaptic que no tengas ningún paquete roto.

Cualquier cosas solo avisas si funciono.

Cambiado el 6 años por erickcion

Salida de la Instalación de Mysql Server

comment:2 Cambiado el 6 años por erickcion

  • Estado cambiado de new to masinfo
  • Hito cambiado de canaima-popular-3.1~VC2 to soporte

He adjuntado el archivo:

attachment:mysql-server-install.log

El cual contiene la salida de una instalación de MySQL Server en un Canaima 3.1 limpio, en el mismo la instalación finaliza exitosamente.

En el adjunto attachment:Pantallazo.png hecho por el usuario se puede leer lo siguiente:

Starting MySQL database server: mysqld....................... failed!
invoke-rc.d: initscript mysql, action "start" failed.

Esto podría deberse a que otro proceso está ocupando el puerto por defecto de mysql, quizás tengas instalado otro programa que esté escuchando por ese puerto.

También es posible que tengas una configuración previa de MySQL en la cual hayas hecho modificaciones erróneas a los archivos de configuración. Es recomendable que ejecutes previamente:

aptitude purgue mysql-server mysql-server-5.1

En la siguiente dirección:

http://us.generation-nt.com/answer/upgrade-mysql-server-5-1-fails-help-198483781.html#198483791

También se encuentra una posible solución que pide eliminar la línea skip-bdb del archivo /etc/mysql/my.cnf, pero dicha linea no está en una instalación limpia. Si la tienes prueba comentándola e intentando de nuevo.

Necesitamos que indiques la información adicional referente a si tenías una instalación previa de mysql o si te funcionó alguno de los métodos antes descritos para continuar dándole seguimiento al reporte.

Se mueve el tique a la cola de soporte hasta que no esté demostrado que se trata a un defecto de desarrollo.

comment:3 Cambiado el 6 años por alqx

  • Estado cambiado de masinfo to assigned

hola muchachos disculpen q no respondi antes, la primera solucion cuando instalo mysql se instala con las dependencias, verifico lo de los paquetes rotos en el synaptic, y no me da aviso, cuando intento darle del dpkg me dice q el paquete 5.1 esta dañado o no se instalo anteriormente.. pense que era el paqueta asi q lo borre y lo volvi a dewscargar y me dio el mismo error

comment:4 Cambiado el 6 años por alqx

  • Estado cambiado de assigned to new
  • Propietario Canaima Popular borrado

cuando intento darle el aptitude purgue mysql-server mysql-server-5.1 me da una lista de opciones que si..

Opciones:
-h This help text.
--no-gui No use la interfaz GTK aunque este disponible.

-s Simula las acciones, pero en realidad no las realiza.
-d Sólo descarga paquetes, no instala o desinstala nada.

-P Always prompt for confirmation or actions.
-y Assume that the answer to simple yes/no questions is 'yes'.
-F format Specify a format for displaying search results; see the manual.
-O order Specify how search results should be sorted; see the manual.
-w width Specify the display width for formatting search results.

-f Trata de arreglar paquetes rotos de forma agresiva.
-V Muestra la versión de los paquetes a instalar.
-D Muestra las dependencias de los paquetes cambiados automáticamente

comment:5 Cambiado el 6 años por erickcion

  • Estado cambiado de new to masinfo

corrijo no es purgue es purge... intentalo así.

Cambiado el 6 años por alqx

comment:6 Cambiado el 6 años por alqx

  • Estado cambiado de masinfo to assigned

eso me da cuando trato de instalarlo manualmente... arriba esta la imagen
borre tambien el apache todo lo purge

Editado por último en fecha 6 años por alqx (anterior) (diferencia)
Nota: Vea TracTickets para ayuda en el uso de incidencias.