Incidencia #586 (new Error)

Abierto hace 5 años

Última modificación 5 años

Paquetes transicionales impiden instalacion de algunos programas

Informado por: erickcion Propietario: Canaima Popular
Prioridad: No Definido Hito: Canaima Popular 4.0~a1
Componente: Canaima Popular Versión: 3.1
Gravedad: Importante Palabras clave: canaima, error, cur
Cc: Asignar A:

Descripción

Estoy probando hacer algunas personalizaciones de mi versión 3.1 de Canaima y se me ha presentado el siguiente problema.

Quiero sustituir el tema de los cursores por defecto de Canaima, el cual es de color verde, por el tema que casi por defecto traen todas las distribuciones que se encuentra en el paquete dmz-cursor-theme.

Al dirigirme al synaptic observo que este paquete a sido sustituido por un paquete transicional que simplemente llama a 'canaima-estilo-visual-iconos-gnome'.

Ya en este punto es un problema porque no cuento en los repositorios de Canaima con el tema de cursores que deseo instalar.

Aun así, no me detengo y busco el paquete original desde el repositorio oficial de Debian y al intentar instalarlo resulta que entra en conflicto con los iconos de Canaima. La salida de DPKG es la siguiente:

# dpkg -i dmz-cursor-theme_0.4.3_all.deb 
dpkg: acerca de dmz-cursor-theme_0.4.3_all.deb que contiene dmz-cursor-theme:
 canaima-estilo-visual-iconos-gnome entra en conflicto con dmz-cursor-theme (<< 1)
  dmz-cursor-theme (versión 0.4.3) va a ser instalado.
dpkg: error al procesar dmz-cursor-theme_0.4.3_all.deb (--install):
 paquetes en conflicto - no se instalará dmz-cursor-theme
Se encontraron errores al procesar:
 dmz-cursor-theme_0.4.3_all.deb

Este error me impide configurar mi computador con el tema de cursores que deseo. Entiendo que este paso se hizo para facilitar la migración de 2.1 a 3.0 pero se convierte un error en un caso como este.

Historial de cambios

comment:1 Cambiado el 5 años por erickcion

Me ha vuelto a suceder este error pero esta vez con el paquete nada trivial de epiphany-browser.

Estoy en la búsqueda de navegadores ligeros para instalar en la mini laptop canaima que tengo con 3.1 y cuando busco los detalles del paquete, este también ha sido convertido en un paquete transicional de actualización.

Lo anterior me resulta en la imposibilidad de instalación de este navegador. Acá abajo está la salida:

# aptitude show epiphany-browser
Paquete: epiphany-browser                        
Estado: sin instalar
Versión: 3.1-12
Prioridad: opcional
Sección: misc
Desarrollador: Equipo de Desarrollo de Canaima GNU/Linux <desarrolladores@canaima.softwarelibre.gob.ve>
Tamaño sin comprimir: 27,6 k
Depende de: canaima-web-gnome (>= 3.1)
Proporcionado por: canaima-web-gnome
Descripción: Paquete transicional epiphany-browser -> canaima-web-gnome
 Esto es un paquete transicional para que los usuarios puedan actualizar de epiphany-browser a canaima-web-gnome sin muchos problemas. Puede ser
 removido.
Página principal: http://canaima.softwarelibre.gob.ve/

comment:2 Cambiado el 5 años por erickcion

  • Gravedad cambiado de Menor to Importante
  • Resumen cambiado de No se puede instalar "dmz-cursor-theme" to Paquetes transicionales impiden instalacion de algunos programas

Cambiaré el titulo a algo que identifique mejor el error ya que no se presenta en un solo paquete.

Nota: Vea TracTickets para ayuda en el uso de incidencias.