Incidencia #693 (new Error)

Abierto hace 5 años

Última modificación 5 años

Cunaguaro debe declarar un conflicto con iceweasel

Informado por: erickcion Propietario: Canaima Popular
Prioridad: Alta Hito: Canaima Popular 4.1~b1
Componente: Canaima Popular Versión: 4.0
Gravedad: Regular Palabras clave: cunaguaro, canaima-web-gnome, iceweasel
Cc: Asignar A:

Descripción

Al tratar de ejecutar la instalación de Cunaguaro en una maquina donde existe IceWeasel? previamente instalado, se genera un conflicto causado por un divert.

A continuación el log:

# aptitude install canaima-web-gnome
Se instalarán los siguiente paquetes NUEVOS:     
  cunaguaro{a} 
Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
  canaima-web-gnome 
0 paquetes actualizados, 1 nuevos instalados, 0 para eliminar y 159 sin actualizar.
Necesito descargar 0 B/2.783 kB de ficheros. Después de desempaquetar se usarán 7.178 kB.
¿Quiere continuar? [Y/n/?] Y
AVISO: ¡se instalarán versiones sin firmar de los siguientes paquetes!

Los paquetes sin firmar pueden comprometer la seguridad del sistema.
Sólo debe continuar con la instalación si está completamente seguro de que es lo
que quiere.

  cunaguaro 

¿Quiere ignorar este aviso y continuar de todos modos?
Para continuar, introduzca "Si"; para abortar, introduzca "No":Si
(Leyendo la base de datos ... 171922 ficheros o directorios instalados actualmente.)
Desempaquetando cunaguaro (de .../cunaguaro_22.0~a2+20130419004013-1_amd64.deb) ...
dpkg-divert: error: `desviación de /usr/bin/firefox a /usr/bin/firefox.real por cunaguaro' entra en conflicto con `desviación de /usr/bin/firefox a /usr/bin/firefox.real por iceweasel'
dpkg: error al procesar /var/cache/apt/archives/cunaguaro_22.0~a2+20130419004013-1_amd64.deb (--unpack):
 el subproceso script pre-installation nuevo devolvió el código de salida de error 2
Procesando disparadores para menu ...
Se encontraron errores al procesar:
 /var/cache/apt/archives/cunaguaro_22.0~a2+20130419004013-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Intentado recuperarse:
dpkg: problemas de dependencias impiden la configuración de canaima-web-gnome:
 canaima-web-gnome depende de cunaguaro; sin embargo:
  El paquete `cunaguaro' no está instalado.

dpkg: error al procesar canaima-web-gnome (--configure):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 canaima-web-gnome

Es necesario que cunaguaro declare conflictos con iceweasel para evitar que se produzca este error. Otra idea seria evitar la generación de este conflicto y permitir de esta forma la coexistencia de ambos programas.

Historial de cambios

comment:1 Cambiado el 5 años por erickcion

  • Hito cambiado de canaima-popular-4.0~a1 to No Definido

comment:2 Cambiado el 5 años por franj

  • Prioridad cambiado de No Definido to Alta
  • Hito cambiado de No Definido to Canaima Popular 4.1~b1
Nota: Vea TracTickets para ayuda en el uso de incidencias.