Incidencia #734 (closed Error: Resuelto)

Abierto hace 5 años

Última modificación 5 años

libreoffice-common impide la actualización de 3.1 a 4.0

Informado por: erickcion Propietario: exodus
Prioridad: No Definido Hito: Canaima Popular 4.0~estable
Componente: Canaima Popular Versión: 4.0
Gravedad: No Definido Palabras clave: libreoffice, libreoffice-common, actualización
Cc: Asignar A:

Descripción (modificado por última vez por erickcion (diferencia)

He estado probando algunos metodos para hacer una actualización desde Canaima 3.1 hacia Canaima 4.0, el método utilizado que más me funciona es:

  • Actualizar todos los paquetes de 3.1
    # apt-get update
    # apt-get upgrade
    
  • Cambiar los repositorio a los de canaima 4.0
# echo "deb http://paquetes.canaima.softwarelibre.gob.ve kerepakupai main aportes no-libres" > /etc/apt/sources.list
# apt-get update
  • Una primera actualización suave
# apt-get upgrade
  • Una actualización completa
# apt-get dist-upgrade

El problema es que durante el proceso libreoffice-common falla durante el proceso de post-instalación, con la siguiente salida:

http://proyectos.canaima.softwarelibre.gob.ve/canaima/pastebin/5#L23

He encontrado algunas referencias en la lista de Debian, pero sin embargo no he encontrado información útil.

http://lists.debian.org/debian-openoffice/2012/04/msg00172.html
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=666523

Adjuntos

canaima-escritorio-gnome_hotfix-3.1-4.0.patch (626 octetos) - añadido por exodus hace 5 años.
1b8e4c07da321b0815939847cd7e7277b5e4a214 hotfix 3.1 - 4.0

Historial de cambios

comment:1 Cambiado el 5 años por erickcion

comment:2 Cambiado el 5 años por erickcion

comment:3 Cambiado el 5 años por erickcion

  • Hito cambiado de No Definido to Canaima Popular 4.0~estable

comment:4 Cambiado el 5 años por exodus

  • Estado cambiado de new to accepted
  • Propietario cambiado de Canaima Popular a exodus

comment:5 Cambiado el 5 años por exodus

Notas Internas:

  • El paquete 'python3' es 'requerido' para la actualización.
  • Aún así, se requiere solucionar el problema de los archivos de configuración de "canaima-escritorio-gnome". Referenciando:

canaima-escritorio-gnome git: http://git.canaima.softwarelibre.gob.ve/?p=canaima-escritorio-gnome.git;a=tree;h=cdb97ab99c6d81d83a0ac9bb7c2b6f84f3003dd0;hb=cdb97ab99c6d81d83a0ac9bb7c2b6f84f3003dd0

Especificamente el prerm:

http://git.canaima.softwarelibre.gob.ve/?p=canaima-escritorio-gnome.git;a=blob;f=debian/prerm;h=b16decd0cf67d1275506ed3ebd1735a04e160ff2;hb=cdb97ab99c6d81d83a0ac9bb7c2b6f84f3003dd0

Editado por último en fecha 5 años por erickcion (anterior) (diferencia)

Cambiado el 5 años por exodus

1b8e4c07da321b0815939847cd7e7277b5e4a214 hotfix 3.1 - 4.0

comment:6 Cambiado el 5 años por exodus

Adjunté un patch.

Lo puedes usar con git apply (Lo generé con git diff). Si vas a usar patch usalo con -p1.

git clone canaima-escritorio-gnome
git checkout 1b8e4c07da321b0815939847cd7e7277b5e4a214
git apply canaima-escritorio-gnome_hotfix-3.1-4.0.patch

Esto es una propuesta. Debería dejar los archivos. Modifica el postrm que es donde realmente se eliminan los archivos.

Saludos.

comment:7 seguimiento: ↓ 8 Cambiado el 5 años por ssolano

Esto se soluciona instalando libreoffice-base https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/926594

comment:8 en respuesta a: ↑ 7 Cambiado el 5 años por ssolano

Replying to ssolano:

Esto se soluciona instalando libreoffice-base https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/926594

libreoffice-base instala todas las dependencias necesarias para continuar con la migración aquí esta una guía donde de se explica de manera detallada el procedimiento http://wiki.canaima.softwarelibre.gob.ve/wiki/Actualizacion_de_canaima_3.1_a_4.0

comment:9 Cambiado el 5 años por ssolano

  • Estado cambiado de accepted to resuelta
  • Resolución establecido a Fijada

comment:10 Cambiado el 5 años por ssolano

  • Estado cambiado de resuelta to closed
Nota: Vea TracTickets para ayuda en el uso de incidencias.