Incidencia #746 (closed Error: Resuelto)

Abierto hace 5 años

Última modificación 5 años

Bienvenido tiene dependencia cruzada con Escritorio-Gnome

Informado por: erickcion Propietario: ssolano
Prioridad: No Definido Hito: Canaima Popular 4.0~b2
Componente: Canaima Popular Versión: 4.0
Gravedad: Regular Palabras clave: canaima-bienvenido
Cc: Asignar A:

Descripción

Al tratar de desinstalar canaima-escritorio-gnome, se esta llevando consigo también a canaima-bienvenido-gnome, lo cual no parece ser el comportamiento correcto.

$ sudo aptitude purge canaima-escritorio-gnome
Se ELIMINARÁN los siguientes paquetes:           
  canaima-escritorio-gnome{p} 
0 paquetes actualizados, 0 nuevos instalados, 1 para eliminar y 2 sin actualizar.
Necesito descargar 0 B de ficheros. Después de desempaquetar se liberarán 2.664 kB.
No se satisfacen las dependencias de los siguientes paquetes:
 canaima-bienvenido-gnome : PreDepende: canaima-escritorio-gnome pero no será instalado.
Las acciones siguientes resolverán estas dependencias

     Eliminar los paquetes siguientes:
1)     canaima-bienvenido-gnome       



¿Acepta esta solución? [Y/n/q/?]

Canaima-Bienvenido está pre-dependiendo de Escritorio-Gnome sin ninguna razón aparente ya no debería haber dependencias hacia arriba con meta-paquetes.

Historial de cambios

comment:1 seguimiento: ↓ 2 Cambiado el 5 años por Axelio

Eh pero si es canaima-bienvenido-gnome, sí debería estar cruzado con escritorio-gnome... ¿Con qué otro escritorio funcionaría canaima-bienvenido-gnome? A menos que canaima-escritorio-gnome sea multiescritorios(?) y entonces dejaría de terminar con -gnome. No sé qué tan equivocado esté, si pueden aclararme por favor...

comment:2 en respuesta a: ↑ 1 Cambiado el 5 años por erickcion

  • Palabras clave canaima-bienvenido añadido; canaima, error eliminados

Replying to Axelio:

Eh pero si es canaima-bienvenido-gnome, sí debería estar cruzado con escritorio-gnome... ¿Con qué otro escritorio funcionaría canaima-bienvenido-gnome? A menos que canaima-escritorio-gnome sea multiescritorios(?) y entonces dejaría de terminar con -gnome. No sé qué tan equivocado esté, si pueden aclararme por favor...


Debes tomar en cuenta que canaima-escritorio-gnome es sólo un meta-paquete, es decir, un paquete que lo unico que hace es depender de otros paquetes, con ello podemos solicitarle a apt que instale las aplicaciones tipicas de Canaima solo pidiendole que instale ese paquete.

Ahora bien, que los demás paquetes de Canaima dependan (hacia arriba) de canaima-escritorio-gnome, es un error que se cometió en Canaima 3.0 y en parte de 3.1, lo cual ocasiono un problema que le dimos el nombre de "dependencias cruzadas". Acá te puedes documentar mejor acerca del caso:

http://erickcion.wordpress.com/2012/11/25/dependencias-y-meta-paquetes-en-canaima-3-x/

Estas dependencias cruzadas ocasionaron que, si por ejemplo no te gustaba "gedit" y lo querías desinstalar, se te iba casi todo el sistema desinstalado gracias a el cruce de dependencias. Esto significó un gran problema para la distro porque el comportamiento correcto debe ser que si desinstalas una aplicacion que es llamada por un meta-paquete, solo debería irse esa aplicación y el meta-paquete.

En el caso que respecta a este ticket, el usuario no debería perder canaima-bienvenido-gnome sólo porque pida, como en el ejemplo anterior, remover el gedit.

comment:4 Cambiado el 5 años por ssolano

  • Propietario cambiado de $USER a ssolano
  • Estado cambiado de new to accepted

comment:5 Cambiado el 5 años por ssolano

  • Estado cambiado de accepted to resuelta
  • Resolución establecido a Fijada

comment:6 Cambiado el 5 años por erickcion

  • Estado cambiado de resuelta to closed
Nota: Vea TracTickets para ayuda en el uso de incidencias.