Incidencia #871 (new Error)

Abierto hace 4 años

Última modificación 4 años

problemas con interfaz gráfica

Informado por: cavillarreal Propietario: $USER
Prioridad: Muy Alta Hito: No Definido
Componente: Canaima Base Versión: No Definido
Gravedad: Importante Palabras clave: canaima, error
Cc: Asignar A:

Descripción

saludos, se me presenta un error al querer instalar una interfaz gráfica desde canaima base. quiero instalar cinnamon. ya actualice el canaima base a la 4.0. tengo los repositorios de canaima y los de linuxmint.
deb http://paquetes.canaima.softwarelibre.gob.ve/ kerepakupai main aportes no-libres

deb http://packages.linuxmint.com/ debian main import backport upstream romeo

y me arroja error de dependencias

No se satisfacen las dependencias de los siguientes paquetes:

cinnamon: Depende: gir1.2-clutter-1.0 que es un paquete virtual.

Depende: gir1.2-glib-2.0 que es un paquete virtual.
Depende: gir1.2-gmenu-3.0 que es un paquete virtual.
Depende: gir1.2-gtk-3.0 que es un paquete virtual.
Depende: gir1.2-networkmanager-1.0 que es un paquete virtual.
Depende: gir1.2-soup-2.4 que es un paquete virtual.
Depende: gnome-bluetooth (>= 3.0.0) pero no será instalado.
Depende: libc6 (>= 2.14) pero está instalado 2.11.3-4.
Depende: libclutter-1.0-0 (>= 1.10.0) pero no será instalado.
Depende: libcogl-pango12 (>= 1.7.4) que es un paquete virtual.
Depende: libcogl12 (>= 1.9.6) que es un paquete virtual.
Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) que es un paquete virtual.
Depende: libgirepository-1.0-1 (>= 0.9.2) que es un paquete virtual.
Depende: libglib2.0-0 (>= 2.35.9) pero está instalado 2.24.2-1.
Depende: libgnome-menu-3-0 (>= 3.2.0.1) que es un paquete virtual.
Depende: libgtk-3-0 (>= 3.0.0) que es un paquete virtual.
Depende: libmozjs185-1.0 (>= 1.8.5-1.0.0+dfsg) que es un paquete virtual.
Depende: libpango-1.0-0 (>= 1.14.0) que es un paquete virtual.
Depende: libpangocairo-1.0-0 (>= 1.14.0) que es un paquete virtual.
Depende: libpulse-mainloop-glib0 (>= 0.99.1) pero está instalado 0.9.21-3+squeeze1.
Depende: libpulse0 (>= 0.99.1) pero está instalado 0.9.21-3+squeeze1.
Depende: libstartup-notification0 (>= 0.11) pero está instalado 0.10-1.
Depende: libxfixes3 (>= 1:5.0) pero está instalado 1:4.0.5-1+squeeze1.
Depende: dconf-gsettings-backend que es un paquete virtual. o

gsettings-backend que es un paquete virtual.

Depende: caribou que es un paquete virtual.
Depende: gnome-icon-theme-symbolic (>= 2.91) pero no será instalado.
Depende: gir1.2-accountsservice-1.0 que es un paquete virtual.
Depende: gir1.2-gconf-2.0 que es un paquete virtual.
Depende: gir1.2-gkbd-3.0 que es un paquete virtual.
Depende: gir1.2-gnomebluetooth-1.0 que es un paquete virtual.
Depende: gir1.2-polkit-1.0 que es un paquete virtual.
Depende: gir1.2-upowerglib-1.0 que es un paquete virtual.
Depende: gir1.2-gtkclutter-1.0 que es un paquete virtual.
Depende: gir1.2-javascriptcoregtk-3.0 que es un paquete virtual.
Depende: gir1.2-webkit-3.0 que es un paquete virtual.

cinnamon-session: Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) que es un paquete virtual.

Depende: libglib2.0-0 (>= 2.32) pero está instalado 2.24.2-1.
Depende: libgtk-3-0 (>= 3.0.0) que es un paquete virtual.
Depende: dconf-gsettings-backend que es un paquete virtual. o

gsettings-backend que es un paquete virtual.

gir1.2-muffin-3.0: Depende: gir1.2-clutter-1.0 que es un paquete virtual.

Depende: gir1.2-freedesktop que es un paquete virtual.
Depende: gir1.2-glib-2.0 que es un paquete virtual.
Depende: gir1.2-gtk-3.0 que es un paquete virtual.

libmuffin0: Depende: libc6 (>= 2.14) pero está instalado 2.11.3-4.

Depende: libcanberra-gtk3-0 (>= 0.25) que es un paquete virtual.
Depende: libclutter-1.0-0 (>= 1.10.0) pero no será instalado.
Depende: libcogl-pango12 (>= 1.7.4) que es un paquete virtual.
Depende: libcogl12 (>= 1.13.4) que es un paquete virtual.
Depende: libegl1-mesa (>= 7.8.1) que es un paquete virtual. o

libegl1-x11 que es un paquete virtual.

Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) que es un paquete virtual.
Depende: libgirepository-1.0-1 (>= 0.9.2) que es un paquete virtual.
Depende: libglib2.0-0 (>= 2.35.9) pero está instalado 2.24.2-1.
Depende: libgtk-3-0 (>= 3.0.8-1~) que es un paquete virtual.
Depende: libjson-glib-1.0-0 (>= 0.12.0) pero no será instalado.
Depende: libpango-1.0-0 (>= 1.14.0) que es un paquete virtual.
Depende: libpangocairo-1.0-0 (>= 1.14.0) que es un paquete virtual.
Depende: libx11-6 (>= 2:1.4.99.1) pero está instalado 2:1.3.3-4+squeeze1.

cjs: Depende: libglib2.0-0 (>= 2.32) pero está instalado 2.24.2-1.
cinnamon-common: Depende: dconf-gsettings-backend que es un paquete virtual. o

gsettings-backend que es un paquete virtual.

gir1.2-cinnamondesktop-3.0: Depende: gir1.2-glib-2.0 que es un paquete virtual.

Depende: gir1.2-gtk-3.0 que es un paquete virtual.

muffin-common: Depende: dconf-gsettings-backend que es un paquete virtual. o

gsettings-backend que es un paquete virtual.

Depende: sgml-base (>= 1.26+nmu2) pero está instalado 1.26+nmu1.

cinnamon-settings-daemon: Depende: libc6 (>= 2.14) pero está instalado 2.11.3-4.

Depende: libcanberra-gtk3-0 (>= 0.25) que es un paquete virtual.
Depende: libcolord1 (>= 0.1.31) que es un paquete virtual.
Depende: libcups2 (>= 1.6.0) pero está instalado 1.4.4-7+squeeze3.
Depende: libfontconfig1 (>= 2.11) pero está instalado 2.8.0-2.1.
Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) que es un paquete virtual.
Depende: libglib2.0-0 (>= 2.35.9) pero está instalado 2.24.2-1.
Depende: libgnomekbd8 (>= 3.6.0) que es un paquete virtual.
Depende: libgnutls26 (>= 2.12.17-0) pero está instalado 2.8.6-1+squeeze2.
Depende: libgtk-3-0 (>= 3.3.16) que es un paquete virtual.
Depende: liblcms2-2 que es un paquete virtual.
Depende: libnotify4 (>= 0.7.3) que es un paquete virtual.
Depende: libpango-1.0-0 (>= 1.14.0) que es un paquete virtual.
Depende: libpangocairo-1.0-0 (>= 1.14.0) que es un paquete virtual.
Depende: libpolkit-gobject-1-0 (>= 0.99) pero está instalado 0.96-4+squeeze2.
Depende: libpulse-mainloop-glib0 (>= 0.99.1) pero está instalado 0.9.21-3+squeeze1.
Depende: libpulse0 (>= 0.99.1) pero está instalado 0.9.21-3+squeeze1.
Depende: libupower-glib1 (>= 0.9.9) pero está instalado 0.9.5-5.
Depende: dconf-gsettings-backend que es un paquete virtual. o

gsettings-backend que es un paquete virtual.

Depende: gsettings-desktop-schemas (>= 3.3.90-0ubuntu2) que es un paquete virtual.

cinnamon-desktop-data: Depende: dconf-gsettings-backend que es un paquete virtual. o

gsettings-backend que es un paquete virtual.

Rompe: gnome-desktop-data (< 1:2.32.1-2) pero está instalado 2.30.2-2.

libcjs0c: Depende: libc6 (>= 2.15) pero está instalado 2.11.3-4.

Depende: libffi6 (>= 3.0.4) que es un paquete virtual.
Depende: libgirepository-1.0-1 (>= 1.31.22) que es un paquete virtual.
Depende: libglib2.0-0 (>= 2.32) pero está instalado 2.24.2-1.
Depende: libmozjs185-1.0 (>= 1.8.5-1.0.0+dfsg) que es un paquete virtual.

libcinnamon-desktop0: Depende: libc6 (>= 2.14) pero está instalado 2.11.3-4.

Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) que es un paquete virtual.
Depende: libglib2.0-0 (>= 2.32) pero está instalado 2.24.2-1.
Depende: libgtk-3-0 (>= 3.3.16) que es un paquete virtual.

nemo-data: Depende: dconf-gsettings-backend que es un paquete virtual. o

gsettings-backend que es un paquete virtual.

Las acciones siguientes resolverán estas dependencias

Mantener los paquetes siguientes en la versión actual:

1) cinnamon [Sin instalar]
2) cinnamon-common [Sin instalar]
3) cinnamon-desktop-data [Sin instalar]
4) cinnamon-session [Sin instalar]
5) cinnamon-settings-daemon [Sin instalar]
6) cjs [Sin instalar]
7) gir1.2-cinnamondesktop-3.0 [Sin instalar]
8) gir1.2-muffin-3.0 [Sin instalar]
9) libcinnamon-desktop0 [Sin instalar]
10) libcjs0c [Sin instalar]
11) libmuffin0 [Sin instalar]
12) muffin-common [Sin instalar]
13) nemo-data [Sin instalar]

¿Acepta esta solución? [Y/n/q/?]

le agradezco la ayuda . muchas gracias

Adjuntos

foto.jpg (163.3 KB) - añadido por cavillarreal hace 4 años.
problema de dependencias

Historial de cambios

Cambiado el 4 años por cavillarreal

problema de dependencias

comment:1 Cambiado el 4 años por arawako

Saludos, no podrás instalar cinnamon desde los repositorios de Linux Mint Debian Edition, la razón es que LMDE se basa en Debian Testing y Canaima se basa en Debian Stable, aparte LMDE tiene los repos de Debian Testing de forma controlada y por ende no son iguales a los de Debian.

La única forma en que puedas instalar Cinnamos en Canaima es que busques una versión de Cinnamon compatible con Debian Wheezy (estable) y la compiles a mano, y si es posible crees tus paquetes para mayor facilidad.

Repito, no se pueden ligar los repositorios de LMDE con Canaima.

Nota: Vea TracTickets para ayuda en el uso de incidencias.