Incidencia #891 (accepted Error)

Abierto hace 4 años

Última modificación 4 años

Problema con actualización de Canaima 4 después de instalado.

Informado por: jsolorzano Propietario: hierro59
Prioridad: Alta Hito: Soporte Técnico
Componente: Canaima Popular Versión: 4.0
Gravedad: Importante Palabras clave: canaima, error
Cc: Asignar A:

Descripción

Se produce un error al actualizar Canaima 4 estable con un apt-get update seguido de un apt-get upgrade. El error sucede cuando el gestor de paquetes (dpkg) intenta reemplazar python 2.7-minimal:

dpkg: error al procesar /var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u2_i386.deb (--unpack):
intentando sobreescribir `/usr/lib/python2.7/lib-dynload/_hashlib.so', que está también en el paquete python2.7 2.7.3-6
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Tubería rota)
Se encontraron errores al procesar:
/var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

La solución encontrada fue forzar el reemplazo del paquete de la siguiente manera:

dpkg -i --force-overwrite /var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u2_i386.deb

Historial de cambios

comment:1 Cambiado el 4 años por deivi

oye METO ESE COMANDO DE DPKG EN TERMINAL Y NO PASA NADA SOY NUEVO EN CANAIMA EXPLÍCAME DETALLADAMENTE COMO SOLUCIONAR ESTO PORFAVOR SOY MUY NUEVO EN CANAIMA ME DICE ESTO AL ABRIR CENTRO DE SOFTWARE >>>>>>

Preparando para reemplazar python2.7-minimal 2.7.3-6 (usando .../python2.7-minimal_2.7.3-6+deb7u3_i386.deb) ...
Desempaquetando el reemplazo de python2.7-minimal ...
dpkg: error al procesar /var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u3_i386.deb (--unpack):

intentando sobreescribir `/usr/lib/python2.7/lib-dynload/_ssl.so', que est tambin en el paquete python2.7 2.7.3-6

dpkg-deb: error: el subproceso copiado fue terminado por la seal (Tubera rota)
Se encontraron errores al procesar:

/var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u3_i386.deb

dpkg: problemas de dependencias impiden la configuracin de libpython2.7:

libpython2.7 depende de python2.7 (= 2.7.3-6+deb7u3); sin embargo:

La versin de `python2.7' en el sistema es 2.7.3-6.

dpkg: error al procesar libpython2.7 (--configure):

problemas de dependencias - se deja sin configurar

Editado por último en fecha 4 años por deivi (anterior) (diferencia)

comment:2 Cambiado el 4 años por hierro59

  • Estado cambiado de new to accepted
  • Propietario cambiado de $USER a hierro59

Este error tiene algún tiempo así, pero lo puedes solucionar siguiendo los

pasos a continuación.

En un terminal de root escribe esto:

rm /var/cache/apt/archives/python2.7-minimal_2.7.3-6+deb7u2_i386.deb

apt-get purge python2.7-minimal

apt-get install python2.7-minimal

Luego efectúa de nuevo la actualización.

Nota: Vea TracTickets para ayuda en el uso de incidencias.