Incidencia #957 (new Error)

Abierto hace 3 años

Error al actualizar la versión 4.1 (PUPPETMASTER)

Informado por: menadaniel Propietario: menadaniel
Prioridad: Alta Hito: Canaima Popular 4.1~b1
Componente: Canaima Popular Versión: 4.1
Gravedad: Importante Palabras clave: canaima, 4.1, codename, release, actualización
Cc: acali@…, dmena@…, crperez@… Asignar A:

Descripción

Se tiene definida un política en el puppetmaster la cual usa un case para identificar que distribución es el nodo (CLIENTE) al cual se la pasará la clase e inyectar unos archivos de configuración distintos para cada distro ya que tenemos varias versiones instaladas.

El problema se presenta con un nodo con Canaima 4.1, al verificar el syslog me percaté de que esa política en especifica daba un error de "Distro no reconocida", al verificar en el cliente efectivamente el codename y el release aparece como n/a

En la política del puppet el case evalúa la variable lsbdistcodename de la herramienta facter, es importante mencionar que ésta política había funcionado y que el caso se presentó luego de un upgrade de los paquetes del cliente Canaima 4.1. Después de la actualización el sistema perdió esa información, habrá alguna corrección para éste error?

Saludos.

Daniel Mena.

P.D: En el archivo .txt que adjunto, se detalla en error del log y un lsb_release -a

Adjuntos

error.txt (853 octetos) - añadido por menadaniel hace 3 años.
syslog y lsb_release -a
history.log (7.6 KB) - añadido por menadaniel hace 3 años.
El history.log se muestra los paquetes que realizaron upgrade y cuales se eliminaron de forma automatica.

Historial de cambios

Cambiado el 3 años por menadaniel

syslog y lsb_release -a

Cambiado el 3 años por menadaniel

El history.log se muestra los paquetes que realizaron upgrade y cuales se eliminaron de forma automatica.

Nota: Vea TracTickets para ayuda en el uso de incidencias.